OrangeScape Developer Community

A community for Application Developers on OrangeScape's Platform-as-a-Service

Record created via SLA is not showing anywhere in the application.

My requirement is as follows.  Every Week on Monday, for every transaction in an activity, i need child records to be created and sent in to workflow.  

I have an action for this requirement. I used New / Append Command to create the new child record.

 

When manually executing the action from the form in runtime, everything happens correctly.  new child is created, and is assigned to the correct person, and shows up in worktop.  

But when the same action is called via SLA, as per the logs, the record is getting created and all corresponding actions are executed.  But, the record is no where to be found.  It does not appear in the admin data viewer also.  On checking the appengine datastore, the record exists, with createdby and modifiedby as guest, and tenant as OS.  Even the corresponding ProcessInstance record has tenant as OS.

Because of this users are complaining of records not appearing in their queues, but receiving assignment intimation mail from the application.  Kindly help solve this issue.

I have attached the SLA log and the data from the DataStore viewer along with this.

Views: 243

Attachments:

Reply to This

Replies to This Discussion

Records getting created/updated via SLA will be performed in the name of anonymous user called guest.

To achieve your requirement, you can update the values of Tenant,Company,CreatedBy, ModifedBy and AssignedTo as needed after the New/Append command.

Hi Vivek,

I tried to update the value of Tenant in New Command, but still the value is being set as OS instead of the corresponding Tenant value.

Vivek,

        As suggested, I tried updating the Tenant Value in the New Command, and also in update command which is called in the child.  But still the result is same.  The Tenant value is getting set as OS.  find attached the logs of the sla execution.

Attachments:

Anbu,

It should work, I don't understand the problem. What abt the other fields?

For Tenant field, Instead of updating via update command try to add it part of company name in process design perspective(Studio) for start activity.

I hope you are talking about this Company Name...

Isn't this option used for restricting a particular company's user to access only that particular company's records.  (multi tenancy - reference :  user model).

I guess you have only one domain, Have you tried this option?

Yes i have only one domain in the application.

Is it working?

I am not understanding what you want me to do?  

Do you want me to keep the tenant in some other field and give it in the Company Name text box?!  or do you want me to do something else.

Anbu,

Hard Code the tenant name in company name text box and try it

Hi Vivek,

I tried what you suggested but still it is not coming up in the dashboard or dataviewer.

Let go one by one, Is Tenant field  is getting updated?

RSS

© 2017   Created by OrangeScape Technologies.   Powered by

Badges  |  Report an Issue  |  Terms of Service